sábado, 14 de abril de 2012

Excel: Verificar se o valor de uma coluna já existe em outra coluna


As vezes precisamos verificar se os valores da Coluna B estão na Coluna A, o excel é uma ferramenta muito poderosa e existem diversas formas para efetuar esta verificação, sendo que a mais simples que encontrei foi a função conte.se().

Segue exemplo:
Linha Coluna A Coluna B
1 1 2
2 8 3
3 3 0
4 4 11
5 6 12
6 2 13
7 2 14
8 5 15
9 5 16

Podemos verificar que os valores das Células B1 e B2 existem na coluna A. Usando a fórmula Conte.se() teremos o total de vezes que estes valores aparecem na coluna A, porém o que precisamos realmente saber é apenas se o valor aparece ao menos uma vez.

A fórmula fica assim para a Primeira célula de B (B1):
=CONT.SE(A:A;B1)

Feito isto é só aplicar ao restante da coluna
Teremos o seguinte resultado:

Linha Coluna A Coluna B Contagem
1 1 2 2
2 8 3 1
3 3 0 0
4 4 11 0
5 6 12 0
6 2 13 0
7 2 14 0
8 5 15 0
9 5 16 0

Para deixar mais elegante é possível colocar uma função de condição: SE(). Quando o valor retornado pela contagem é maior que 0 escreve VERDADEIRO, senão escreve FALSO.

A fórmula final ficará assim:
=SE(CONT.SE(A:A;B2)>0;VERDADEIRO;FALSO)

Veja a resultado final:

Linha Coluna A Coluna B Contagem Verificação
1 1 2 2 VERDADEIRO
2 8 3 1 VERDADEIRO
3 3 0 0 FALSO
4 4 11 0 FALSO
5 6 12 0 FALSO
6 2 13 0 FALSO
7 2 14 0 FALSO
8 5 15 0 FALSO
9 5 16 0 FALSO
Até a próxima

Veja Também:
Como fazer um CPF ficar formatado corretamente em Máscara para CPF no EXCEL
Como fazer um CNPJ ficar formatado corretamente em Máscara para CNPJ no EXCEL
Como Ordenar Tabelas em: Ordenando dados de Colunas no Excel

3 comentários: