quarta-feira, 2 de maio de 2012

Error: XML: Cacti version does not exist.

Erro ao importar templates no Cacti.

Quando encontrar o erro "Error: XML: Cacti version does not exist." ao importar um template no CACTI, significa que o array de versões do cacti está desatualizado.
para acertar é simples.
Entre no diretório de códigos fontes do cacti então entre em include e altere o arquivo  global_array.php Em máquinas linux com RedHat ou derivados (Centos Fedora) o cacti tem os códigos fontes instalados por padrão em /var/www/cacti.

O array vai ficar assim:
$hash_version_codes = array(
        "0.8.4"  => "0000",
        "0.8.5"  => "0001",
        "0.8.5a" => "0002",
        "0.8.6"  => "0003",
        "0.8.6a" => "0004",
        "0.8.6b" => "0005",
        "0.8.6c" => "0006",
        "0.8.6d" => "0007",
        "0.8.6e" => "0008",
        "0.8.6f" => "0009",
        "0.8.6g" => "0010",
        "0.8.6h" => "0011",
        "0.8.6i" => "0012",
        "0.8.6j" => "0013",
        "0.8.7"  => "0014",
        "0.8.7a" => "0015",
        "0.8.7b" => "0016",
        "0.8.7c" => "0017",
        "0.8.7d" => "0018",
        "0.8.7e" => "0019",
        "0.8.7f" => "0020",
        "0.8.7g" => "0021",
        "0.8.7h" => "0022",
        "0.8.7i" => "0023",
        "0.8.8" => "0024"
        );

Nenhum comentário:

Postar um comentário